use strict;
my $str = 'ä
&zuml
ö
ë
';
my $regex = qr/&([aeoz])uml\b/mp;
my $subst = ' $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";