package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)&([aeoz])uml\b`)
var str = `ä
&zuml
ö
ë
`
var substitution = " $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}