#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^20120(7(1[5-9]|2\d|3[01])|8([0-1]\d|20))\d{4}$"
Local $sString = "201207141240" & @CRLF & _
"201207150000" & @CRLF & _
"201207160733" & @CRLF & _
"201208010648" & @CRLF & _
"201208191606" & @CRLF & _
"201208202359" & @CRLF & _
"201208210000" & @CRLF & _
"201208311919" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")