const regex = /^20120(7(1[5-9]|2\d|3[01])|8([0-1]\d|20))\d{4}$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^20120(7(1[5-9]|2\\d|3[01])|8([0-1]\\d|20))\\d{4}$', 'gmi')
const str = `201207141240
201207150000
201207160733
201208010648
201208191606
201208202359
201208210000
201208311919
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}