$re = '/^20120(7(1[5-9]|2\d|3[01])|8([0-1]\d|20))\d{4}$/mi';
$str = '201207141240
201207150000
201207160733
201208010648
201208191606
201208202359
201208210000
201208311919
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);