// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^20120(7(1[5-9]|2\d|3[01])|8([0-1]\d|20))\d{4}$").unwrap();
let string = "201207141240
201207150000
201207160733
201208010648
201208191606
201208202359
201208210000
201208311919
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}