use strict;
my $str = '201207141240
201207150000
201207160733
201208010648
201208191606
201208202359
201208210000
201208311919
';
my $regex = qr/^20120(7(1[5-9]|2\d|3[01])|8([0-1]\d|20))\d{4}$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}