import re
regex = re.compile(r"^20120(7(1[5-9]|2\d|3[01])|8([0-1]\d|20))\d{4}$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("201207141240\n"
"201207150000\n"
"201207160733\n"
"201208010648\n"
"201208191606\n"
"201208202359\n"
"201208210000\n"
"201208311919\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")