import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^20120(7(1[5-9]|2\\d|3[01])|8([0-1]\\d|20))\\d{4}$";
final String string = "201207141240\n"
+ "201207150000\n"
+ "201207160733\n"
+ "201208010648\n"
+ "201208191606\n"
+ "201208202359\n"
+ "201208210000\n"
+ "201208311919\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}