#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/t\.me\/\w{5,}$"
Local $sString = "https://t.me/httd1" & @CRLF & _
"https://t.me/botfather" & @CRLF & _
"https://t.me/telegrambrasil" & @CRLF & _
"http://t.me/telegrambrasil" & @CRLF & _
"https://t.m/telegrambrasil" & @CRLF & _
"https://t.me/tele" & @CRLF & _
"http;/t.me\llllll" & @CRLF & _
"text message https://t.me/telegrambrasil"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")