using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/t\.me\/\w{5,}$";
string input = @"https://t.me/httd1
https://t.me/botfather
https://t.me/telegrambrasil
http://t.me/telegrambrasil
https://t.m/telegrambrasil
https://t.me/tele
http;/t.me\llllll
text message https://t.me/telegrambrasil";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}