import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/t\\.me\\/\\w{5,}$";
final String string = "https://t.me/httd1\n"
+ "https://t.me/botfather\n"
+ "https://t.me/telegrambrasil\n"
+ "http://t.me/telegrambrasil\n"
+ "https://t.m/telegrambrasil\n"
+ "https://t.me/tele\n"
+ "http;/t.me\\llllll\n"
+ "text message https://t.me/telegrambrasil";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}