const regex = /^https?:\/\/t\.me\/\w{5,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/t\\.me\\\/\\w{5,}$', 'gm')
const str = `https://t.me/httd1
https://t.me/botfather
https://t.me/telegrambrasil
http://t.me/telegrambrasil
https://t.m/telegrambrasil
https://t.me/tele
http;/t.me\\llllll
text message https://t.me/telegrambrasil`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}