// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https?:\/\/t\.me\/\w{5,}$").unwrap();
let string = "https://t.me/httd1
https://t.me/botfather
https://t.me/telegrambrasil
http://t.me/telegrambrasil
https://t.m/telegrambrasil
https://t.me/tele
http;/t.me\\llllll
text message https://t.me/telegrambrasil";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}