using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(x)\]|\[(\d*)\]";
string substitution = @"";
string input = @"""[x] Alpha
[33] Beta]""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}