$re = '/\[(x)\]|\[(\d*)\]/';
$str = '"[x] Alpha
[33] Beta]"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;