import Foundation
let pattern = #"\[(x)\]|\[(\d*)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"[x] Alpha
[33] Beta]"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)