use strict;
my $str = '"[x] Alpha
[33] Beta]"';
my $regex = qr/\[(x)\]|\[(\d*)\]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";