const regex = /\[(x)\]|\[(\d*)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(x)\\]|\\[(\\d*)\\]', 'g')
const str = `"[x] Alpha
[33] Beta]"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);