import re
regex = re.compile(r"\[(x)\]|\[(\d*)\]")
test_str = ("\"[x] Alpha\n\n"
"[33] Beta]\"")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)