# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*100\s*%.*?\r?\n//si;t' <<< "Verification 97% complete.
Verification 98% complete.
Verification 98% complete.
Verification 99% complete.
Verification 99% complete.
Verification 100% complete.
Foo
bar
baz"