#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?si)^.*100\s*%.*?\r?\n"
Local $sString = "Verification 97% complete. " & @CRLF & _
"Verification 98% complete." & @CRLF & _
"Verification 98% complete." & @CRLF & _
"Verification 99% complete." & @CRLF & _
"Verification 99% complete." & @CRLF & _
"Verification 100% complete." & @CRLF & _
"Foo" & @CRLF & _
"bar" & @CRLF & _
"baz"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)