import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*100\\s*%.*?\\r?\\n";
final String string = "Verification 97% complete. \n"
+ "Verification 98% complete.\n"
+ "Verification 98% complete.\n"
+ "Verification 99% complete.\n"
+ "Verification 99% complete.\n"
+ "Verification 100% complete.\n"
+ "Foo\n"
+ "bar\n"
+ "baz";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}