# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*100\s*%.*?\r?\n"
test_str = ("Verification 97% complete. \n"
"Verification 98% complete.\n"
"Verification 98% complete.\n"
"Verification 99% complete.\n"
"Verification 99% complete.\n"
"Verification 100% complete.\n"
"Foo\n"
"bar\n"
"baz")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.DOTALL | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.