# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Z][a-z]+)|([A-Z]+(?=[A-Z]))|(\d+)/$1 $2 $3/g;t' <<< "SomeEquipmentHere
ABSBrakes
CDRadio
Valve14"