$re = '/([A-Z][a-z]+)|([A-Z]+(?=[A-Z]))|(\d+)/';
$str = 'SomeEquipmentHere
ABSBrakes
CDRadio
Valve14';
$subst = "$1 $2 $3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;