import Foundation
let pattern = #"([A-Z][a-z]+)|([A-Z]+(?=[A-Z]))|(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
SomeEquipmentHere
ABSBrakes
CDRadio
Valve14
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2 $3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)