import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z][a-z]+)|([A-Z]+(?=[A-Z]))|(\\d+)";
final String string = "SomeEquipmentHere\n"
+ "ABSBrakes\n"
+ "CDRadio\n"
+ "Valve14";
final String subst = "$1 $2 $3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}