use strict;
my $str = 'SomeEquipmentHere
ABSBrakes
CDRadio
Valve14';
my $regex = qr/([A-Z][a-z]+)|([A-Z]+(?=[A-Z]))|(\d+)/p;
my $subst = '$1 $2 $3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";