# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<[^<>]*>//gm;t' <<< "<p>Environments subject.</p>
<ul><li> property ;</li></ul><ul><li>markets and exchange;</li></ul>
<p class=\"MsoNormal\" style=\"margin: 0cm 0cm 0pt;\">"