use strict;
my $str = '<p>Environments subject.</p>
<ul><li> property ;</li></ul><ul><li>markets and exchange;</li></ul>
<p class="MsoNormal" style="margin: 0cm 0cm 0pt;">';
my $regex = qr/<[^<>]*>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";