# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\bid="[^"]*?)\s/_/gm;t' <<< "this is a sample id=\"aaa bbb ccc\" name=\"abc abc\""