$re = '/(?<=\bid="[^"]*?)\s/m';
$str = 'this is a sample id="aaa bbb ccc" name="abc abc"';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;