using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\bid=""[^""]*?)\s";
string substitution = @"_";
string input = @"this is a sample id=""aaa bbb ccc"" name=""abc abc""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}