re = /(?<=\bid="[^"]*?)\s/m
str = 'this is a sample id="aaa bbb ccc" name="abc abc"'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result