use strict;
my $str = 'this is a sample id="aaa bbb ccc" name="abc abc"';
my $regex = qr/(?<=\bid="[^"]*?)\s/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";