#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\bid="[^"]*?)\s"
Local $sString = "this is a sample id="aaa bbb ccc" name="abc abc""
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)