import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((.*(\\\\|\\/))*\\.settings(.*(\\\\|\\/))*.*)|((.*(\\\\|\\/))*\\.metadata(.*(\\\\|\\/))*.*)|(exe|war|ear|class|zip|7z|iso|tar|car|dll)$";
final String string = ".settings\n"
+ "abc\\.settings\n"
+ "abc/.settings\n"
+ "abc.class\n"
+ "adb.ear\n"
+ "abd.war\n"
+ "abc.jar\n"
+ "asc.sa\n"
+ "abc/.metadata\\abc.ear\n"
+ "abc/.settings\\abc.ear\n"
+ ".settings\n"
+ ".metadata\n"
+ ".classpath\n"
+ "abc/xyz/ac.zip\n"
+ "abc.classpath\n"
+ "abc/classpath/.classpath/abc\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}