# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((.*(\\|\/))*\.settings(.*(\\|\/))*.*)|((.*(\\|\/))*\.metadata(.*(\\|\/))*.*)|(exe|war|ear|class|zip|7z|iso|tar|car|dll)$"
test_str = (".settings\n"
"abc\\.settings\n"
"abc/.settings\n"
"abc.class\n"
"adb.ear\n"
"abd.war\n"
"abc.jar\n"
"asc.sa\n"
"abc/.metadata\\abc.ear\n"
"abc/.settings\\abc.ear\n"
".settings\n"
".metadata\n"
".classpath\n"
"abc/xyz/ac.zip\n"
"abc.classpath\n"
"abc/classpath/.classpath/abc\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.