import Foundation
let pattern = #"((.*(\\|\/))*\.settings(.*(\\|\/))*.*)|((.*(\\|\/))*\.metadata(.*(\\|\/))*.*)|(exe|war|ear|class|zip|7z|iso|tar|car|dll)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.settings
abc\.settings
abc/.settings
abc.class
adb.ear
abd.war
abc.jar
asc.sa
abc/.metadata\abc.ear
abc/.settings\abc.ear
.settings
.metadata
.classpath
abc/xyz/ac.zip
abc.classpath
abc/classpath/.classpath/abc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)