const regex = /((.*(\\|\/))*\.settings(.*(\\|\/))*.*)|((.*(\\|\/))*\.metadata(.*(\\|\/))*.*)|(exe|war|ear|class|zip|7z|iso|tar|car|dll)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((.*(\\\\|\\\/))*\\.settings(.*(\\\\|\\\/))*.*)|((.*(\\\\|\\\/))*\\.metadata(.*(\\\\|\\\/))*.*)|(exe|war|ear|class|zip|7z|iso|tar|car|dll)$', 'gm')
const str = `.settings
abc\\.settings
abc/.settings
abc.class
adb.ear
abd.war
abc.jar
asc.sa
abc/.metadata\\abc.ear
abc/.settings\\abc.ear
.settings
.metadata
.classpath
abc/xyz/ac.zip
abc.classpath
abc/classpath/.classpath/abc
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}