re = /((.*(\\|\/))*\.settings(.*(\\|\/))*.*)|((.*(\\|\/))*\.metadata(.*(\\|\/))*.*)|(exe|war|ear|class|zip|7z|iso|tar|car|dll)$/m
str = '.settings
abc\\.settings
abc/.settings
abc.class
adb.ear
abd.war
abc.jar
asc.sa
abc/.metadata\\abc.ear
abc/.settings\\abc.ear
.settings
.metadata
.classpath
abc/xyz/ac.zip
abc.classpath
abc/classpath/.classpath/abc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end