// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?m)((.*(\\|\/))*\.settings(.*(\\|\/))*.*)|((.*(\\|\/))*\.metadata(.*(\\|\/))*.*)|(exe|war|ear|class|zip|7z|iso|tar|car|dll)$").unwrap();
  let string = ".settings
abc\\.settings
abc/.settings
abc.class
adb.ear
abd.war
abc.jar
asc.sa
abc/.metadata\\abc.ear
abc/.settings\\abc.ear
.settings
.metadata
.classpath
abc/xyz/ac.zip
abc.classpath
abc/classpath/.classpath/abc
";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}