#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^newcommand\{(.*?)\}\{((?:(?!^newcommand).)+)\}"
Local $sString = "newcommand{commandName1}{This is first command}" & @CRLF & _
"" & @CRLF & _
"newcommand{commandName2}{This is second command with {} brackets inside" & @CRLF & _
"in multiple lines {} {}" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"newcommand{commandName3}{This is third, last command}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")