import re
regex = re.compile(r"^newcommand\{(.*?)\}\{((?:(?!^newcommand).)+)\}", flags=re.MULTILINE | re.DOTALL)
test_str = ("newcommand{commandName1}{This is first command}\n\n"
"newcommand{commandName2}{This is second command with {} brackets inside\n"
"in multiple lines {} {}\n"
"}\n\n"
"newcommand{commandName3}{This is third, last command}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")