using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^newcommand\{(.*?)\}\{((?:(?!^newcommand).)+)\}";
string input = @"newcommand{commandName1}{This is first command}
newcommand{commandName2}{This is second command with {} brackets inside
in multiple lines {} {}
}
newcommand{commandName3}{This is third, last command}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}