re = /^newcommand\{(.*?)\}\{((?:(?!^newcommand).)+)\}/m
str = 'newcommand{commandName1}{This is first command}
newcommand{commandName2}{This is second command with {} brackets inside
in multiple lines {} {}
}
newcommand{commandName3}{This is third, last command}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end