const regex = new RegExp('^newcommand\\{(.*?)\\}\\{((?:(?!^newcommand).)+)\\}', 'gms')
const str = `newcommand{commandName1}{This is first command}
newcommand{commandName2}{This is second command with {} brackets inside
in multiple lines {} {}
}
newcommand{commandName3}{This is third, last command}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}