$re = '/^newcommand\{(.*?)\}\{((?:(?!^newcommand).)+)\}/ms';
$str = 'newcommand{commandName1}{This is first command}
newcommand{commandName2}{This is second command with {} brackets inside
in multiple lines {} {}
}
newcommand{commandName3}{This is third, last command}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);