import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^newcommand\\{(.*?)\\}\\{((?:(?!^newcommand).)+)\\}";
final String string = "newcommand{commandName1}{This is first command}\n\n"
+ "newcommand{commandName2}{This is second command with {} brackets inside\n"
+ "in multiple lines {} {}\n"
+ "}\n\n"
+ "newcommand{commandName3}{This is third, last command}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}